PSIRT Advisories

OpenSSL3 CVE-2022-3602 CVE-2022-3786 vulnerabilities

Summary

CVE-2022-3602:
A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed the malicious certificate or for the application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address to overflow four attacker-controlled bytes on the stack. This buffer overflow could result in a crash (causing a denial of service) or potentially remote code execution. Many platforms implement stack overflow protections which would mitigate against the risk of remote code execution. The risk may be further mitigated based on stack layout for any given platform/compiler. Pre-announcements of CVE-2022-3602 described this issue as CRITICAL. Further analysis based on some of the mitigating factors described above have led this to be downgraded to HIGH. Users are still encouraged to upgrade to a new version as soon as possible. In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects.

 

CVE-2022-3786:
A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed a malicious certificate or for an application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address in a certificate to overflow an arbitrary number of bytes containing the `.' character (decimal 46) on the stack. This buffer overflow could result in a crash (causing a denial of service). In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects.  

 

Both the vulnerabilities are fixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6).

 

Affected Products

Vulnerable Products
FortiOS v7.2.1 and v7.2.2


Products Confirmed not Vulnerable
FortiOS all versions up to 7.2.0 (included) 
FortiADC
FortiADCManager
FortiAIOps
FortiAnalyzer
FortiAnalyzer-BigData
FortiAP
FortiAP-C
FortiAP-S
FortiAP-U
FortiAuthenticator
FortiCASB
FortiCentral
FortiClientEMS
FortiClientLinux
FortiClientMac
FortiClientWindows
FortiConnect
FortiConverter
FortiDeceptor
FortiDevSec
FortiEdge
FortiEDR
FortiFone
FortiGuest
FortiInsight
FortiIsolator
FortiLANCloud
FortiMail
FortiManager
FortiMoM
FortiNAC
FortiNDR
FortiPAM
FortiPentest
FortiPhish
FortiPolicy
FortiPortal
FortiPresence
FortiProxy
FortiRecorder
FortiSandbox
FortiSIEM
FortiSOAR
FortiTester
FortiTokenAndroid
FortiTokenIOS
FortiVoiceEnterprise
FortiVoiceUC
FortiVoiceUCDesktop
FortiWAN
FortiWeb
FortiWebManager
FortiWLC
FortiWLM
FortiSASE
FortiSwitchManager
FortiToken Cloud
FortiWebCloud
FortiAPCloud
FortiCloud
FortiDDoS-F
FortiDDoS
FortiDeceptor
FortiSwitch
FortiSandbox Cloud
FortiExtender Cloud
FortiClient Cloud
FortiLANCloud
FortiAnalyzer Cloud
FortiManager Cloud

Solutions

Please upgrade to FortiOS version 7.2.3 or above