FortiWeb - Heap based overflow in CLI


A buffer overflow vulnerability [CWE-122] in the the command line interpreter of FortiWeb may allow an authenticated attacker to achieve arbitrary code execution via specifically crafted arguments to existing commands.

Affected Products

FortiWeb version 7.0.0 through 7.0.1
FortiWeb version 6.3.0 through 6.3.19
FortiWeb 6.4 all versions
FortiWeb 6.2 all versions
FortiWeb 6.1 all versions
FortiWeb 6.0 all versions


Upgrade to FortiWeb 7.0.2 or above,
upgrade to FortiWeb 6.3.20 or above.


Internally discovered and reported by Gwendal Guégniaud of Fortinet Product Security Team.