PSIRT Advisories

Multiple Apache Vulnerabilities fixed in 2.4.52

Summary

The Apache project released an advisory, describing the following vulnerabilities:


1) CVE-2021-44790

A carefully crafted request body can cause a buffer overflow in the mod_lua 
multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not 
aware of an exploit for the vulnerabilty though it might be possible to craft one. This 
issue affects Apache HTTP Server 2.4.51 and earlier.

2) CVE-2021-44224

A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash 
(NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, 
can allow for requests to be directed to a declared Unix Domain Socket endpoint 
(Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included).

 

Affected Products

The following products are NOT impacted:
FortiOS
FortiManager
FortiAnalyzer
FortiAuthenticator
FortiIsolator
FortiProxy
FortiSandbox
FortiWLM
FortiMail 
FortiAP
FortiDeceptor
FortiRecorder
FortiWeb
FortiWLC
FortiPortal 
FortiSIEM
FortiSwitch
FortiClientEMS
FortiVoiceEnterprise
FortiPentest
FortiNDR
FortiNAC
FortiAnalyzer-BD