PSIRT Advisories

FortiPortal - XML parser is vulnerable to XXE attacks

Summary

An improper restriction of XML external entity reference vulnerability [CWE-611] in the parser of XML responses of FortiPortal may allow an attacker who controls the producer of XML reports consumed by FortiPortal to trigger a denial of service or read arbitrary files from the underlying file system by means of specifically crafted XML documents.

Affected Products

FortiPortal version 6.0.5 and below.
FortiPortal version 5.3.6 and below.
FortiPortal version 5.2.6 and below.
FortiPortal version 5.1.2 and below.
FortiPortal version 5.0.3 and below.
FortiPortal version 4.2.4 and below.
FortiPortal version 4.1.2 and below.
FortiPortal version 4.0.4 and below.

Solutions

Upgrade to FortiPortal version 6.0.6 or above.
Upgrade to FortiPortal version 5.3.7 or above.
Upgrade to FortiPortal version 5.2.7 or above.

Acknowledgement

Internally discovered and reported by Giuseppe Cocomazzi of Fortinet Product Security team.