FortiAuthenticator - Command injection in CLI

FortiAuthenticator - Command injection in CLI

Summary

An improper neutralization of special elements used in an OS command vulnerability [CWE-78]  in the command line interpreter of FortiAuthenticator may allow an authenticated attacker to execute unauthorized commands via specifically crafted arguments to existing commands.

Affected Products

FortiAuthenticator 6.3.0 and below.
FortiAuthenticator 6.2.1 and below.
FortiAuthenticator 6.2.0 and below.

Solutions

Upgrade to FortiAuthenticator 6.4.0 or above.
Upgrade to FortiAuthenticator 6.3.1 or above.

Acknowledgement

Internally discovered and reported by Giuseppe Cocomazzi of Fortinet Product Security team.