PSIRT Advisories

FortiSandbox - Command injection in web interface

Summary

An improper neutralization of special elements used in an OS Command vulnerability in FortiSandbox may allow an authenticated attacker with access to the web GUI to execute unauthorized code or commands via specifically crafted HTTP requests.

Affected Products

FortiSandbox 3.2.2 and below.
FortiSandbox 3.1.4 and below.
FortiSandbox 3.0.6 and below.

Solutions

Upgrade to FortiSandbox 4.0.0 or above.

Upgrade to FortiSandbox 3.2.3 or above.

Upgrade to FortiSandbox 3.1.5 or above.

Upgrade to FortiSandbox 3.0.7 or above.

Acknowledgement

Internally discovered and reported by Giuseppe Cocomazzi of Fortinet Product Security team.