PSIRT Advisory

FortiWeb is vulnerable to a buffer overflow

Summary

A stack-based buffer overflow vulnerability in FortiWeb may allow a remote, unauthenticated attacker to crash the httpd daemon thread by sending a request with a crafted cookie header.

Impact

Denial of service

Affected Products

FortiWeb versions 6.3.7 and below. 

FortiWeb versions 6.2.3 and below.

Solutions

Please upgrade to FortiWeb versions 6.3.8 or above. 

Please upgrade to FortiWeb versions 6.2.4 or above.

Acknowledgement

Fortinet is pleased to thank Andrey Medov from ptsecurity for reporting this vulnerability under responsible disclosure.