Stack-Based Buffer Overflow vulnerability in FortiWeb

Stack-Based Buffer Overflow vulnerability in FortiWeb

Summary

A stack-based buffer overflow vulnerability in FortiWeb may allow an unauthenticated, remote attacker to overwrite the content of the stack and potentially execute arbitrary code by sending a crafted request with a large certname.

Impact

Execute unauthorized code or commands

Affected Products

FortiWeb versions 6.3.5 and below. 

FortiWeb versions 6.2.3 and below.

Solutions

Please upgrade to FortiWeb versions 6.3.6 or above. 

Please upgrade to FortiWeb versions 6.2.4 or above.

Acknowledgement

Fortinet is pleased to thank Andrey Medov from ptsecurity for reporting this vulnerability under responsible disclosure.