PSIRT Advisory

XSS vulnerability in FortiWeb

Summary

An improper neutralization of input during web page generation in FortiWeb GUI interface may allow an unauthenticated, remote attacker to perform a reflected cross site scripting attack (XSS) by injecting malicious payload in different vulnerable API end-points.

Impact

Execute unauthorized code or commands

Affected Products

FortiWeb versions 6.3.7 and below. FortiWeb versions 6.2.3 and below.

Solutions

Please upgrade to FortiWeb versions 6.3.8 or above. Please upgrade to FortiWeb versions 6.2.4 or above.

Acknowledgement

Fortinet is pleased to thank Andrey Medov from ptsecurity for reporting this vulnerability under responsible disclosure.