PSIRT Advisories

FortiAnalyzer - XSS vulnerability observed in the Column settings of LogView

Summary

An improper neutralization of input vulnerability [CWE-79] in FortiAnalyzer may allow a remote authenticated attacker to perform a stored cross site scripting attack (XSS) via the column settings of Logview in FortiAnalyzer, should the attacker be able to obtain that POST request, via other, hypothetical attacks.

Affected Products

FortiAnalyzer version 6.4.3 and below.
FortiAnalyzer version 6.2.7 and below.
FortiAnalyzer version 6.0.x.

Solutions

Please upgrade to FortiAnalyzer version 6.4.4 or above.

Please upgrade to FortiAnalyzer version 6.2.8 or above.

 

Workaround:

Disable Log View/Fortiview access.
config system admin profile
edit set log-viewer none
next
end

Acknowledgement

Fortinet is pleased to thank Frank Cozijnsen of the KPN REDteam for reporting this vulnerability under responsible disclosure.