Threat Encyclopedia

Moodle.Teacher.Enrollment.Privilege.Elevation

description-logoDescription

This indicates an attack attempt to exploit an Elevation Of Privilege Vulnerability in Moodle.
The vulnerability is due to an error in the vulnerable application when handling a maliciously crafted HTTP request. A remote attacker may be able to exploit this to leverage their privileges on vulnerable systems.

affected-products-logoAffected Products

Moodle version 3.9
Moodle version 3.8 to 3.8.3
Moodle version 3.7 to 3.7.6
Moodle version 3.5 to 3.5.12
Moodle version prior to above version

Impact

Privilege Escalation: Remote attackers can leverage their privileges on vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://moodle.org/mod/forum/discuss.php?d=407393

CVE References

CVE-2020-14321