Intrusion Prevention

Nagios.XI.users.php.do_update_user.Stored.XSS

Description

This indicates an attack attempt to exploit a Cross-Site Scripting Vulnerability in Nagios Enterprises Nagios XI.
The vulnerability is due to insufficient validation of the phone parameter in users.php. A remote authenticated attacker can exploit this vulnerability by sending a crafted request to the server. Successful exploitation could result in the execution of script code in security context of the target user's browser.

Affected Products

Nagios Enterprises Nagios XI prior to 5.7.3

Impact

System Compromise: Remote attackers can execute arbitrary script code in the context of the affected application.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.nagios.com/downloads/nagios-xi/change-log/