Intrusion Prevention

cURL.and.libcurl.TFTP.blksize.Heap.Buffer.Overflow

Description

This indicates an attack attempt to exploit a Buffer Overflow Vulnerability in cURL Project libcURL.
A remote attacker can exploit this vulnerability by enticing a user to connect to a TFTP server with a crafted blksize value. Successful exploitation can lead to the attacker being able to execute arbitrary code with the privileges of the application.

Affected Products

cURL Project cURL 7.19.4 through 7.65.3
cURL Project libcURL 7.19.4 through 7.65.3

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://curl.haxx.se/docs/CVE-2019-5436.html

CVE References

CVE-2019-5482 CVE-2019-5436