Threat Encyclopedia

Grandstream.Devices.Invalid.Phonecookie.Command.Injection

description-logoDescription

This indicates an attack attempt to exploit a Command Execution vulnerability in multiple Grandstream devices.
The vulnerability is caused by an error when the vulnerable software handles a malicious HTTP request. A remote attacker may be able to exploit this to execute arbitrary code on vulnerable systems.

affected-products-logoAffected Products

Grandstream GAC2500 1.0.3.35
Grandstream GXP2200 1.0.3.27
Grandstream GVC3202 1.0.3.51
Grandstream GXV3275 before 1.0.3.219 Beta
Grandstream GXV3240 before 1.0.3.219 Beta

Impact

System Compromise: Remote attackers can gain control of vulnerable system.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
http://www.grandstream.com/

CVE References

CVE-2019-10655