Threat Encyclopedia

Mozilla.Firefox.HTML5.Fragments.Heap.Buffer.Overflow

description-logoDescription

This indicates an attack attempt to exploit a Heap Buffer Overflow in Mozilla Firefox.
The vulnerability is due to an error in the HTML5 parser when handling a maliciously crafted HTML file. A remote attacker may be able to exploit this by tricking a user into visiting a malicious web page and execute arbitrary code within the context of the application.

affected-products-logoAffected Products

Mozilla Firefox before 47.0 and Firefox ESR 45.x before 45.2

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor:
https://www.mozilla.org/en-US/security/advisories/mfsa2016-50/

CVE References

CVE-2016-2819