Threat Encyclopedia

VMware.VNC.VMWDynResolution.Heap.Buffer.Overflow

description-logoDescription

This indicates an attack attempt to exploit a Buffer Overflow Vulnerability in VMWare Workstation.
The vulnerability is due to an error in the vulnerable application when handling a maliciously crafted request. An attacker can exploit this to execute arbitrary commands or cause a denial of service condition on the affected machine via a crafted request.

affected-products-logoAffected Products

VMWare ESXi 6.5 prior to ESXi650-201710401-BG
VMWare Fusion prior to 8.5.9
VMWare Workstation prior to 12.5.8

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor:
https://www.vmware.com/security/advisories/VMSA-2017-0021.html

CVE References

CVE-2017-4933