Intrusion Prevention

Node.js.normalize.Handling.Security.Bypass

Description

This indicates an attack attempt to exploit a Security Bypass Vulnerability in Node.js.
The vulnerability is caused by improper validation of user supplied data when the vulnerable application handles a maliciously crafted request. An attacker can exploit this to execute arbitrary code in the context of the vulnerable application via a crafted request.

Affected Products

Node.js 8.5.0 before 8.6.0

Impact

Security Bypass: Remote attackers can bypass security checking of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor. Or follow the workaround in below link.
https://github.com/nodejs/node/releases

CVE References

CVE-2017-14849