Intrusion Prevention

Adobe.Flash.RegExp.Multiple.Recursion.DoS

Description

This indicates an attack attempt to exploit a Denial of Service vulnerability in Adobe Flash Player.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted SWF file. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application. Also a remote attacker may be able to exploit this to cause denial of services conditions within the context of the application.

Affected Products

Adobe Flash Player 15.0.0.167 and earlier versions
Adobe Flash Player 13.0.0.244 and earlier 13.x versions
Adobe Flash Player 11.2.202.406 and earlier versions for Linux
Adobe AIR desktop runtime 15.0.0.249 and earlier versions
Adobe AIR SDK 15.0.0.249 and earlier versions
Adobe AIR SDK & Compiler 15.0.0.249 and earlier versions
Adobe AIR 15.0.0.252 and earlier versions for Android

Impact

Denial of Service: Remote attackers can crash vulnerable systems.
System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://helpx.adobe.com/security/products/flash-player/apsb14-22.html

CVE References

CVE-2014-0564