Threat Encyclopedia

OpenSSL.c_rehash.Script.Command.Injection

description-logoDescription

This indicates an attack attempt to exploit a Command Injection Vulnerability in OpenSSL Project OpenSSL.
The vulnerability is due to improper validation of shell metacharacters. A remote attacker could exploit the vulnerability by enticing the target user to parse malicious files. Successful exploitation could result in command execution within the context of the target user.

affected-products-logoAffected Products

OpenSSL Project OpenSSL 3.0.0
OpenSSL Project OpenSSL 3.0.1
OpenSSL Project OpenSSL 3.0.2
OpenSSL Project OpenSSL prior to 1.1.1o

Impact logoImpact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.openssl.org/news/secadv/20220503.txt

CVE References

CVE-2022-1292