Threat Encyclopedia

RHSA-2021:1608-Security Advisory

Description

The vulnerabilities in the following products could cause the system to become vulnerable to malicious security attack: python-cryptography

Analysis

The python-cryptography packages contain a Python Cryptographic Authority's (PyCA's) cryptography library, which provides cryptographic primitives and recipes to Python developers. The following packages have been upgraded to a later upstream version: python-cryptography (3.2.1). (BZ#1873581, BZ#1891947) Security Fix(es): python-cryptography: bleichenbacher timing oracle attack against RSA decryption (CVE-2020-25659) python-cryptography: certain sequences of update() calls when symmetrically encrypting very large payloads could result in an integer overflow and lead to buffer overflows (CVE-2020-36242) python-cryptography: bleichenbacher timing oracle attack against RSA decryption (CVE-2020-25659) python-cryptography: certain sequences of update() calls when symmetrically encrypting very large payloads could result in an integer overflow and lead to buffer overflows (CVE-2020-36242) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the Red Hat Enterprise Linux 8.4 Release Notes linked from the References section. SolutionFor details on how to apply this update, which includes the changes described in this advisory, refer to:https://access.redhat.com/articles/11258

Affected Products

python-cryptography