Zero-Day Advisory

Fortinet Discovers Adobe Illustrator Buffer Overflow Vulnerability

Summary

Fortinet's FortiGuard Labs has discovered a buffer overflow vulnerability in Adobe Illustrator.


Adobe Illustrator is a vector graphics editor developed and published by Adobe Systems for macOS and Windows.


A buffer overflow vulnerability has been discovered in Illustrator by FortiGuard Labs. The vulnerability is caused by a crafted PCT file which causes an out-of-bounds memory access. It could allow malicious users to create code execution scenarios.

Solutions

FortiGuard Labs released the following FortiGate IPS signature which covers this specific vulnerability:

Adobe.Illustrator.CVE-2022-23187.Arbitrary.Code.Execution
Released Jan 19, 2022

Users should apply the solution provided by Adobe.

Timeline

Fortinet reported the vulnerability to Adobe on November 08, 2021.

Adobe confirmed the vulnerability on January 14, 2022.

Adobe patched the vulnerability on March 08, 2022.

Acknowledgement

This vulnerability was discovered by Kushal Arvind Shah of Fortinet's FortiGuard Labs.

IPS Subscription

Fortinet customers who subscribe to Fortinet's intrusion prevention (IPS) service should be protected against this vulnerability with the appropriate configuration parameters in place. Fortinet's IPS service is one component of FortiGuard Subscription Services, which also offer comprehensive solutions such as antivirus, Web content filtering and antispam capabilities. These services enable protection against threats on both application and network layers. FortiGuard Services are continuously updated by FortiGuard Labs, which enables Fortinet to deliver a combination of multi-layered security intelligence and true zero-day protection from new and emerging threats. These updates are delivered to all FortiGate, FortiMail and FortiClient products. Fortinet strictly follows responsible disclosure guidelines to ensure optimum protection during a threat's lifecycle.