Threat Encyclopedia

OMRON.CX-One.CX-FLnet.cdmapi32.wcscpy.Buffer.Overflow

description-logoDescription

This indicates an attack attempt to exploit a Buffer Overflow Vulnerability in OMRON CX-One CX-FLnet.
The vulnerability is due to input validation error when processing TargetPLC parameter of the FLN configuration file. A remote attacker could exploit this vulnerability by enticing a target user into opening a maliciously crafted project file. Successful exploitation could result in arbitrary code execution in the context of the target user. Unsuccessful exploitation could result in termination of the application.

affected-products-logoAffected Products

OMRON CX-One 4.60 and prior
OMRON CX-One CX-FLnet versions 1.1 and prior

Impact logoImpact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.cisa.gov/uscert/ics/advisories/icsa-22-006-01

CVE References

CVE-2022-21137

Other References

ICSA-22-006-01

Telemetry logoTelemetry