Threat Encyclopedia

Delta.IA.CNCSoft.ScreenEditor.CVE-2021-43982.Buffer.Overflow

description-logoDescription

This indicates an attack attempt to exploit a Buffer Overflow Vulnerability in Delta Electronics CNCSoft.
The vulnerability is due to lack of proper validation of the length of user-supplied data prior to copying to a fixed-length stack buffer. A remote attacker can exploit this vulnerability by enticing a target user into opening a crafted DPB file. Successful exploitation could result in execution of arbitrary code under the security context of the current process.

affected-products-logoAffected Products

Delta Electronics CNCSoft 1.01.30 and prior

Impact logoImpact

Delta Electronics CNCSoft 1.01.30 and prior

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://us-cert.cisa.gov/ics/advisories/icsa-21-334-03

CVE References

CVE-2021-43982

Other References

ICSA-21-334-03

Telemetry logoTelemetry