Threat Encyclopedia

Delta.Industrial.Automation.DIALink.events.Stored.XSS

description-logoDescription

This indicates an attack attempt to exploit a Cross-Site Scripting Vulnerability in Delta Electronics DIALink.
The vulnerability is due to input validation error when processing comment parameter in events endpoint. A remote, authenticated attacker can exploit this vulnerability with crafted requests to the target server. Successful exploitation could result in arbitrary script execution in the target user's browser.

affected-products-logoAffected Products

Delta Electronics DIALink 1.3.1.0 and prior

Impact logoImpact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.cisa.gov/uscert/ics/advisories/icsa-21-294-02

CVE References

CVE-2021-38488

Other References

ICSA-21-294-02

Telemetry logoTelemetry