Threat Encyclopedia

Delta.Industrial.Automation.DIAEnergie.hierarchyHandler.XSS

description-logoDescription

This indicates an attack attempt to exploit a Cross-Site Scripting Vulnerability in Delta Electronics DIAEnergie.
The vulnerability is due to input validation error when processing parameters in DIAE_hierarchyHandler.ashx endpoint. A remote, unauthenticated attacker can exploit this vulnerability with crafted requests to the target server. Successful exploitation could result in arbitrary script execution in the target user's browser.

affected-products-logoAffected Products

Delta Electronics DIAEnergie 1.7.5 and prior

Impact

System Compromise: Remote attackers can execute arbitrary script code in the context of the affected application.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://downloadcenter.deltaww.com/en-US/DownloadCenter?v=1&CID=06&itemID=060702&sort_expr=cdate&sort_dir=DESC

Telemetry

CVE References

CVE-2021-31558

Other References

ICSA-21-238-03