Threat Encyclopedia

Advantech.WebAccess.IOCTL.10001.BwFreRPT.Buffer.Overflow

description-logoDescription

This indicates an attack attempt to exploit a Buffer Overflow Vulnerability in Advantech WebAccess.
This vulnerability is due to missing input validation while processing input in BwFreRPT component. A remote, unauthenticated attacker can exploit this vulnerability by sending a crafted request to the target system. Successful exploitation could result in remote code execution on the target system under the context of the current user.

affected-products-logoAffected Products

Advantech WebAccess 9.0.0 upto 9.0.3

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.advantech.com/industrial-automation/webaccess