Threat Encyclopedia

GitLab.Community.and.Enterprise.Edition.Notes.Stored.XSS

description-logoDescription

This indicates an attack attempt to exploit a Cross-Site Scripting Vulnerability in GitLab Community Edition (CE) and Enterprise Edition (EE).
The vulnerability is due to improper sanitization of user input submitted in notes. A remote, authenticated attacker can exploit this vulnerability by by sending a crafted request to the target server. Successful exploitation could result in arbitrary script execution in the security context of the target user's browser.

affected-products-logoAffected Products

GitLab Community Edition (CE) and Enterprise Edition (EE) 14.4 prior to 14.7.7
GitLab Community Edition (CE) and Enterprise Edition (EE) 14.8.x prior to 14.8.5
GitLab Community Edition (CE) and Enterprise Edition (EE) 14.9.x prior to 14.9.2

Impact logoImpact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://about.gitlab.com/releases/2022/03/31/critical-security-release-gitlab-14-9-2-released/#stored-xss-in-notes

CVE References

CVE-2022-1175

Telemetry logoTelemetry