Threat Encyclopedia

Aruba.Instant.cp-upload.Arbitrary.File.Write

description-logoDescription

This indicates an attempt to exploit an Arbitrary File Write in Aruba Instant.
The vulnerability is due to insufficient validation of user supplied inputs to "/swarm.cgi". An authenticated remote attacker can exploit the vulnerability by sending crafted requests to the server. Successful exploitation could result in an arbitrary file upload.

affected-products-logoAffected Products

Aruba Instant 6.4.x: 6.4.4.8-4.2.4.17 and prior
Aruba Instant 6.5.x: 6.5.4.18 and prior
Aruba Instant 8.3.x: 8.3.0.14 and prior
Aruba Instant 8.5.x: 8.5.0.11 and prior
Aruba Instant 8.6.x: 8.6.0.7 and prior
Aruba Instant 8.7.x: 8.7.1.1 and prior

Impact logoImpact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2021-007.txt

CVE References

CVE-2021-25159

Telemetry logoTelemetry