Threat Encyclopedia

Centreon.hostGroupDependency.php.dep_id.SQL.Injection

Description

This indicates an attack attempt to exploit an SQL Injection Vulnerability in Centreon Project Centreon.
The vulnerability is due to incorrect input validation in hostGroupDependency.php. A remote, authenticated attacker could exploit this vulnerability by sending a maliciously crafted request to the server. A successful attack may result in arbitrary SQL command execution against the database on the target server.

Affected Products

Centreon Project Centreon 20.04.x before 20.04.16
Centreon Project Centreon 20.10.x before 20.10.9
Centreon Project Centreon 21.04.x before 21.04.3

Impact

System Compromise: Remote attackers can add, view, delete or modify data in the database of the affected application

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://github.com/centreon/centreon/releases