Threat Encyclopedia

Jenkins.GitHub.Plugin.CSRF

description-logoDescription

This indicates an attack attempt against a Cross-Site Request-Forgery vulnerability in Jenkins Github Plugin.
The vulnerability is due to insufficient sanitization of user supplied inputs in the application. An attacker may exploit this to cause the server to perform certain actions in the context of an authorized user's session and gain unauthorized access to the affected application.

affected-products-logoAffected Products

Jenkins GitHub Plugin 1.29.1 and earlier

Impact

Information Disclosure: Remote attackers can gain sensitive information from vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://jenkins.io/security/advisory/2018-06-25/#SECURITY-915

CVE References

CVE-2018-1000600