Threat Encyclopedia

FreeBSD.NFS.Server.nfsm_advance.DoS

description-logoDescription

This indicates an attack attempt to exploit a Denial of Service Vulnerability in FreeBSD Project FreeBSD
A remote attacker, who has access to a NFS file system, could exploit this vulnerability by sending a crafted NFSv4 SETCLIENTID request to the target server. Successful exploitation would cause a kernel panic resulting in denial-of-service conditions.

affected-products-logoAffected Products

FreeBSD Project FreeBSD 11.0-Stable prior to r340854
FreeBSD Project FreeBSD 11.2-Releng prior to r341088

Impact

Denial of Service: Remote attackers can crash vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.freebsd.org/security/advisories/FreeBSD-SA-18:13.nfs.asc

CVE References

CVE-2018-17158