Threat Encyclopedia

Adobe.Reader.Distiller.Engine.PostScript.Heap.Overflow

description-logoDescription

This indicates an attack attempt to exploit a Heap Overflow vulnerability in Adobe Acrobat and Reader.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted PostScript file. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted PostScript file.

affected-products-logoAffected Products

Adobe Acrobat DC Continuous for Windows and macOS 2018.011.20058 and earlier versions
Adobe Acrobat Reader DC Continuous for Windows and macOS 2018.011.20058 and earlier versions
Acrobat 2017 Classic 2017 for Windows and macOS 2017.011.30099 and earlier versions
Acrobat Reader DC 2017 Classic 2017 for Windows and macOS 2017.011.30099 and earlier versions
Acrobat DC Classic 2015 for Windows and macOS 2015.006.30448 and earlier versions
Acrobat Reader DC Classic 2015 for Windows and macOS 2015.006.30448 and earlier versions

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://helpx.adobe.com/security/products/acrobat/apsb18-30.html

CVE References

CVE-2018-12833

Other References

APSB18-30