Threat Encyclopedia

MS.NET.Framework.Workflow.Remote.Code.Execution

description-logoDescription

This indicates an attack attempt to exploit a Remote Code Execution vulnerability in Microsoft .NET Framework.
The vulnerability is due to insufficient sanitizing of user supplied inputs in the application. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted request.

affected-products-logoAffected Products

Microsoft .NET Framework 4.5.2 on Windows 7 for 32-bit Systems Service Pack 1
Microsoft .NET Framework 4.5.2 on Windows 7 for x64-based Systems Service Pack 1
Microsoft .NET Framework 4.5.2 on Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Microsoft .NET Framework 4.5.2 on Windows Server 2008 R2 for x64-based Systems Service Pack 1
Microsoft .NET Framework 4.5.2 on Windows Server 2012
Microsoft .NET Framework 4.5.2 on Windows Server 2012 (Server Core installation)
Microsoft .NET Framework 4.5.2 on Windows 8.1 for 32-bit systems
Microsoft .NET Framework 4.5.2 on Windows 8.1 for x64-based systems
Microsoft .NET Framework 4.5.2 on Windows Server 2012 R2
Microsoft .NET Framework 4.5.2 on Windows RT 8.1
Microsoft .NET Framework 4.5.2 on Windows Server 2012 R2 (Server Core installation)
Microsoft .NET Framework 4.5.2 on Windows Server 2008 for 32-bit Systems Service Pack 2
Microsoft .NET Framework 4.5.2 on Windows Server 2008 for x64-based Systems Service Pack 2
Microsoft .NET Framework 4.6 on Windows Server 2008 for 32-bit Systems Service Pack 2
Microsoft .NET Framework 4.6 on Windows Server 2008 for x64-based Systems Service Pack 2
Microsoft .NET Framework 4.7.2 on Windows 10 Version 1803 for 32-bit Systems
Microsoft .NET Framework 4.7.2 on Windows 10 Version 1803 for x64-based Systems
Microsoft .NET Framework 4.7.2 on Windows Server, version 1803 (Server Core Installation)
Microsoft .NET Framework 4.6/4.6.1/4.6.2 on Windows 10 for 32-bit Systems
Microsoft .NET Framework 4.6/4.6.1/4.6.2 on Windows 10 for x64-based Systems
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows 7 for 32-bit Systems Service Pack 1
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows 7 for x64-based Systems Service Pack 1
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows Server 2008 R2 for x64-based Systems Service Pack 1
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows Server 2012
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows Server 2012 (Server Core installation)
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows 8.1 for 32-bit systems
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows 8.1 for x64-based systems
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows Server 2012 R2
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows RT 8.1
Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2 on Windows Server 2012 R2 (Server Core installation)
Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2 on Windows Server 2016
Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2 on Windows 10 Version 1607 for 32-bit Systems
Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2 on Windows 10 Version 1607 for x64-based Systems
Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2 on Windows Server 2016 (Server Core installation)
Microsoft .NET Framework 4.7/4.7.1/4.7.2 on Windows 10 Version 1703 for 32-bit Systems
Microsoft .NET Framework 4.7/4.7.1/4.7.2 on Windows 10 Version 1703 for x64-based Systems
Microsoft .NET Framework 4.7.1/4.7.2 on Windows 10 Version 1709 for 32-bit Systems
Microsoft .NET Framework 4.7.1/4.7.2 on Windows 10 Version 1709 for x64-based Systems
Microsoft .NET Framework 4.7.1/4.7.2 on Windows Server, version 1709 (Server Core Installation)
Microsoft .NET Framework 3.5 on Windows Server 2012
Microsoft .NET Framework 3.5 on Windows Server 2012 (Server Core installation)
Microsoft .NET Framework 3.5 on Windows 8.1 for 32-bit systems
Microsoft .NET Framework 3.5 on Windows 8.1 for x64-based systems
Microsoft .NET Framework 3.5 on Windows Server 2012 R2
Microsoft .NET Framework 3.5 on Windows Server 2012 R2 (Server Core installation)
Microsoft .NET Framework 3.5 on Windows 10 for 32-bit Systems
Microsoft .NET Framework 3.5 on Windows 10 for x64-based Systems
Microsoft .NET Framework 3.5 on Windows Server 2016
Microsoft .NET Framework 3.5 on Windows 10 Version 1607 for 32-bit Systems
Microsoft .NET Framework 3.5 on Windows 10 Version 1607 for x64-based Systems
Microsoft .NET Framework 3.5 on Windows Server 2016 (Server Core installation)
Microsoft .NET Framework 3.5 on Windows 10 Version 1703 for 32-bit Systems
Microsoft .NET Framework 3.5 on Windows 10 Version 1703 for x64-based Systems
Microsoft .NET Framework 3.5 on Windows 10 Version 1709 for 32-bit Systems
Microsoft .NET Framework 3.5 on Windows 10 Version 1709 for x64-based Systems
Microsoft .NET Framework 3.5 on Windows Server, version 1709 (Server Core Installation)
Microsoft .NET Framework 3.5 on Windows 10 Version 1803 for 32-bit Systems
Microsoft .NET Framework 3.5 on Windows 10 Version 1803 for x64-based Systems
Microsoft .NET Framework 3.5 on Windows Server, version 1803 (Server Core Installation)
Microsoft .NET Framework 3.0 Service Pack 2 on Windows Server 2008 for Itanium-Based Systems Service Pack 2
Microsoft .NET Framework 3.0 Service Pack 2 on Windows Server 2008 for 32-bit Systems Service Pack 2
Microsoft .NET Framework 3.0 Service Pack 2 on Windows Server 2008 for x64-based Systems Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2 on Windows Server 2008 for Itanium-Based Systems Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2 on Windows Server 2008 for 32-bit Systems Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2 on Windows Server 2008 for x64-based Systems Service Pack 2
Microsoft .NET Framework 3.5.1 on Windows 7 for 32-bit Systems Service Pack 1
Microsoft .NET Framework 3.5.1 on Windows 7 for x64-based Systems Service Pack 1
Microsoft .NET Framework 3.5.1 on Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Microsoft .NET Framework 3.5.1 on Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Microsoft .NET Framework 3.5.1 on Windows Server 2008 R2 for x64-based Systems Service Pack 1

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-8284

CVE References

CVE-2018-8284