Intrusion Prevention

Digium.Asterisk.res_pjsip_pubsub.Out.of.Bounds.Write

Description

This indicates an attack attempt to exploit a Out of Bounds Write Vulnerability in Digium Asterisk.
The vulnerability is due to an error when the vulnerable module handles malicious SIP requests. A remote attacker may be able to exploit this to cause a denial of service condition or even perform arbitrary code execution on the affected system.

Affected Products

Digium Asterisk Open Source 13.x prior to 13.19.2
Digium Asterisk Open Source 14.x prior to 14.7.6
Digium Asterisk Open Source 15.x prior to 15.2.2
Digium Certified Asterisk 13.18 prior to 13.18-cert3

Impact

Denial of Service: Remote attackers can crash vulnerable systems.
System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor:
http://downloads.asterisk.org/pub/security/AST-2018-004.html

CVE References

CVE-2018-7284