Threat Encyclopedia

Adobe.Flash.PSDK.Object.Use.After.Free

description-logoDescription

This indicates an attack attempt to exploit an Use After Free vulnerability in Adobe Flash Player.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted SWF file. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted SWF file.

affected-products-logoAffected Products

Adobe Flash Player Desktop Runtime for Windows 28.0.0.137
Adobe Flash Player Desktop Runtime for Macintosh 28.0.0.13
Adobe Flash Player Desktop Runtime for Linux 28.0.0.137
Adobe Flash Player Google Chrome Plugin for Windows 28.0.0.137
Adobe Flash Player Google Chrome Plugin for Macintosh 28.0.0.137
Adobe Flash Player Google Chrome Plugin for Linux 28.0.0.137
Adobe Flash Player Google Chrome Plugin for ChromeOS 28.0.0.137
Adobe Flash Player Microsoft Edge and Internet Explorer 11 Plugin for Windows 10 and Windows 8.1 28.0.0.137

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://helpx.adobe.com/security/products/flash-player/apsb18-03.html

CVE References

CVE-2018-4877