Threat Encyclopedia

Samba.SMB1.smb_request_done.Use.After.Free

description-logoDescription

This indicates an attack attempt to exploit a Remote Code Execution vulnerability in Samba.
The vulnerability is caused by an error when the vulnerable software handles a specially crafted request. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application.

affected-products-logoAffected Products

Samba Team Samba 4.0.0 to 4.7.3
Samba Team Samba 4.0.0 to 4.6.11
Samba Team Samba 4.0.0 to 4.5.15

Impact

System Compromise: Remote attackers can gain control of vulnerable systems

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.samba.org/samba/security/CVE-2017-14746.html

CVE References

CVE-2017-14746