Intrusion Prevention

Adobe.Flash.Flash10e.ocx.Integer.Overflow

Description

This indicates an attack attempt to exploit a memory-corruption vulnerability
in Adobe Flash Player.
The vulnerability is caused by an error when the vulnerable software handles a malicious .swf file. An attacker may exploit this by sending a malicious .swf file.

Affected Products

Adobe Flash Player 10.0.45.2 and prior versions

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the patch supplied by the vendor:
http://www.adobe.com/support/security/bulletins/apsb10-14.html

CVE References

CVE-2010-2183