Intrusion Prevention

PhotoFiltre.Studio.Buffer.Overflow

Description

This indicates an attack attempt against a buffer-overflow vulnerability in PhotoFiltre Studio.
The vulnerability is caused by an error when the vulnerable software handles a malicious .tif file. It allows a remote attacker to execute arbitrary code via sending a crafted .tif file.

Affected Products

Photofiltre Studio versions 8.1.1 and 10.3.0; other versions may also be affected.

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are not aware of any official patch for this issue.

CVE References

CVE-2007-2192