Threat Encyclopedia

XWiki.deleteAttachment.Stored.XSS

description-logoDescription

This indicates an attack attempt to exploit a Cross-Site Scripting Vulnerability in XWiki.org XWiki.
The vulnerability is due to insufficient validation of deleted attachment file names. A remote, authenticated attacker could exploit this vulnerability by sending a crafted request to the target server. Successful exploitation could result in the execution of script code in the security context of a target user's browser.

affected-products-logoAffected Products

XWiki.org XWiki 13.x prior to 13.10.6
XWiki.org XWiki 14.x prior to 14.3

Impact logoImpact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-gjmq-x5x7-wc36

CVE References

CVE-2022-36096