Threat Encyclopedia

Pimcore.GridHelperService.php.SQL.Injection

description-logoDescription

This indicates an attack attempt to exploit an SQL Injection Vulnerability in Pimcore.
This vulnerability is due to improper input validation for /grid-proxy, /get-export-jobs, and /get-batch-jobs APIs. A remote, authenticated attacker could exploit this vulnerability by sending a crafted request to the target server. Successfully exploiting this vulnerability could result in SQL injection.

affected-products-logoAffected Products

Pimcore prior to 10.3.6

Impact logoImpact

System Compromise: Remote attackers can add, view, delete or modify data in the database of the affected application

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://github.com/pimcore/pimcore/commit/523a735ab94f004459b84ffdfd3db784586bbd82

CVE References

CVE-2022-1429