Threat Encyclopedia

Apache.Struts.OGNL.BeanMap.Remote.Code.Execution

description-logoDescription

This indicates an attack attempt to exploit a Remote Code Execution Vulnerability in Apache Software Foundation Struts.
The vulnerability is due to insufficient input validation leading to a forced double OGNL evaluation when evaluating raw user input. A remote attacker can exploit this vulnerability by sending a crafted HTTP request containing a malicious parameter to a vulnerable server. Successful exploitation could result in the execution of arbitrary code with the privileges of the server.

affected-products-logoAffected Products

Apache Software Foundation Struts 2.0.0 through 2.5.25

Impact logoImpact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://cwiki.apache.org/confluence/display/WW/S2-061

CVE References

CVE-2021-31805