Threat Encyclopedia

Adobe.Commerce.Magento.Remote.Code.Execution

description-logoDescription

Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during the checkout process. Exploitation of this issue does not require user interaction and could result in arbitrary code execution.

affected-products-logoAffected Products

Adobe Commerce2.4.3-p1 and earlier versions
Adobe Commerce2.3.7-p2 and earlier versions
Magento Open Source 2.4.3-p1 and earlier versions
Magento Open Source 2.3.7-p2 and earlier versions

Impact logoImpact

System Compromise: Remote attackers can gain control of vulnerable systems.

recomended-action-logoRecommended Actions

Apply the most recent upgrade or patch from the vendor.
https://helpx.adobe.com/security/products/magento/apsb22-12.html

CVE References

CVE-2022-24086