Threat Encyclopedia

Security Vulnerability CVE-2021-22931 for Nodejs

Description

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.

Affected Products

Nodejs

CVE References

CVE-2021-22931