Threat Encyclopedia

RHSA-2021:2361-Security Advisory

Description

The vulnerabilities in the following products could cause the system to become vulnerable to malicious security attack: postgresql

Analysis

PostgreSQL is an advanced object-relational database management system (DBMS). The following packages have been upgraded to a later upstream version: postgresql (10.17). Security Fix(es): postgresql: Buffer overrun from integer overflow in array subscripting calculations (CVE-2021-32027) postgresql: Memory disclosure in INSERT ... ON CONFLICT ... DO UPDATE (CVE-2021-32028) postgresql: Buffer overrun from integer overflow in array subscripting calculations (CVE-2021-32027) postgresql: Memory disclosure in INSERT ... ON CONFLICT ... DO UPDATE (CVE-2021-32028) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. SolutionFor details on how to apply this update, which includes the changes described in this advisory, refer to:https://access.redhat.com/articles/11258 If the postgresql service is running, it will be automatically restarted after installing this update.

Affected Products

postgresql