Threat Encyclopedia

RHSA-2021:1746-Security Advisory

Description

The vulnerabilities in the following products could cause the system to become vulnerable to malicious security attack: delve

Analysis

Go Toolset provides the Go programming language tools and libraries. Go is alternatively known as golang. The following packages have been upgraded to a later upstream version: golang (1.15.7), delve (1.5.0). (BZ#1870531) Security Fix(es): golang: crypto/elliptic: incorrect operations on the P-224 curve (CVE-2021-3114) golang: cmd/go: packages using cgo can cause arbitrary code execution at build time (CVE-2021-3115) golang: crypto/elliptic: incorrect operations on the P-224 curve (CVE-2021-3114) golang: cmd/go: packages using cgo can cause arbitrary code execution at build time (CVE-2021-3115) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the Red Hat Enterprise Linux 8.4 Release Notes linked from the References section. SolutionFor details on how to apply this update, which includes the changes described in this advisory, refer to:https://access.redhat.com/articles/11258

Affected Products

delve

CVE References

CVE-2021-3115 CVE-2021-3114