Threat Encyclopedia

RHSA-2021:1600-Security Advisory

Description

The vulnerabilities in the following products could cause the system to become vulnerable to malicious security attack: opensc

Analysis

The OpenSC set of libraries and utilities provides support for working with smart cards. OpenSC focuses on cards that support cryptographic operations and enables their use for authentication, mail encryption, or digital signatures. Security Fix(es): opensc: heap-based buffer overflow in sc_oberthur_read_file (CVE-2020-26570) opensc: stack-based buffer overflow in sc_pkcs15emu_gemsafeGPK_init (CVE-2020-26571) opensc: stack-based buffer overflow in tcos_decipher (CVE-2020-26572) opensc: heap-based buffer overflow in sc_oberthur_read_file (CVE-2020-26570) opensc: stack-based buffer overflow in sc_pkcs15emu_gemsafeGPK_init (CVE-2020-26571) opensc: stack-based buffer overflow in tcos_decipher (CVE-2020-26572) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the Red Hat Enterprise Linux 8.4 Release Notes linked from the References section. SolutionFor details on how to apply this update, which includes the changes described in this advisory, refer to:https://access.redhat.com/articles/11258

Affected Products

opensc