Threat Encyclopedia

Security Vulnerability CVE-2018-9838 for OCaml

description-logoDescription

The caml_ba_deserialize function in byterun/bigarray.c in the standard library in OCaml 4.06.0 has an integer overflow which, in situations where marshalled data is accepted from an untrusted source, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a crafted object.

affected-products-logoAffected Products

OCaml

CVE References

CVE-2018-9838