Intrusion Prevention

Red.Hat.JBoss.RichFaces.MediaOutputResource.EL.Code.Injection

Description

This indicates an attack attempt to exploit a Code Injection vulnerability in JBoss RichFaces.
The vulnerability is due to insufficient sanitizing of user supplied URI inputs into the application. A remote attacker can exploit this to send a crafted query to execute arbitrary commands on a vulnerable server.

Affected Products

JBoss RichFaces before 4.5.4
JBoss RichFaces 4.5.3 through 4.5.17

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor:
https://access.redhat.com/security/cve/CVE-2015-0279
https://access.redhat.com/security/cve/CVE-2018-12532

CVE References

CVE-2018-12532 CVE-2015-0279